Jump to content


Photo
- - - - -

Heating Issue

fan coolant res

  • Please log in to reply
17 replies to this topic

#1 Quadsey

Quadsey

    sticking around

  • Member
  • 22 posts
  • Location:Dublin
  • TDM model: 2006

Posted 06 May 2019 - 02:08 pm

Hey Guys, I'm still finding my way around my TDM 900 twin and today i decided to flush the cooling system because the bike is overheating in city driving conditions.

There are two main issues. 1. the fan doesn't seem to be coming on regardless of temp and 2. the coolant reservoir was empty.

 

So firstly after stripping the radiator off completely to access the fan, i found the fan is moving freely and has no signs of wear. It has been suggested to me to check "a switch" or "thermostat", i was unable to spot either. Does this sound like it could be the issue? Where are they located ( a photo pointing them out would be nice)

 

Secondly the coolant reservoir is completely empty, is this simply an issue of low coolant level or is there an issue with circulation?

 

Any help would be greatly appreciated, thanks.


"Touch not, less ye be touched" -Brodie 1995


#2 PICARD

PICARD

    has been here 4ever

  • Supporting Member(thanks)
  • PipPipPipPipPipPipPipPip
  • 1,182 posts
  • Location:Wirral / wherever I lay my hat!
  • TDM model: 2004

Posted 06 May 2019 - 03:38 pm

Well, I'd start with the simple things. If the coolant level is low,top up the reservoir and preferably the radiator to, by removing the cap and brimming it. Then try running the engine up again to see if the fan starts. Does the temp gauge rise? It's normal to get almost into the red before the fan starts. While you're in there, wire the fan directly to a power source ie battery, to see if it will run. If it runs like this,and the gauge gets to the red while the fan is wired as it should be....start looking for the switch.
Lock onto my co-ordinates and beam me up !!

04 900 - 92 mk 1 - r 1150 rs - Z550 A1 - 2x bonnies - plastic slug -XL185 - ...not in that order !! (and one or two i don't want / dare to own up to !!)

#3 Quadsey

Quadsey

    sticking around

  • Member
  • 22 posts
  • Location:Dublin
  • TDM model: 2006

Posted 06 May 2019 - 05:15 pm

Well, I'd start with the simple things. If the coolant level is low,top up the reservoir and preferably the radiator to, by removing the cap and brimming it. Then try running the engine up again to see if the fan starts. Does the temp gauge rise? It's normal to get almost into the red before the fan starts. While you're in there, wire the fan directly to a power source ie battery, to see if it will run. If it runs like this,and the gauge gets to the red while the fan is wired as it should be....start looking for the switch.

I've just done a coolant flush and change so i'll have to wait until tomorrow to see if its done anything for it.

Yes the temp gauge does rise and in relation to the fan its wiring seems to be sealed to the back of it so not accessible to wire an external power source.


"Touch not, less ye be touched" -Brodie 1995


#4 PICARD

PICARD

    has been here 4ever

  • Supporting Member(thanks)
  • PipPipPipPipPipPipPipPip
  • 1,182 posts
  • Location:Wirral / wherever I lay my hat!
  • TDM model: 2004

Posted 06 May 2019 - 05:25 pm

Follow the cable, I think there a terminal block into the harness where before it enters the frame tunnel.
Lock onto my co-ordinates and beam me up !!

04 900 - 92 mk 1 - r 1150 rs - Z550 A1 - 2x bonnies - plastic slug -XL185 - ...not in that order !! (and one or two i don't want / dare to own up to !!)

#5 dablik

dablik

    Master Intermediate Fettlin' Award 2018

  • Supporting Member(thanks)
  • PipPipPipPipPipPipPipPip
  • 8,328 posts
  • Location:Bootleshire
  • TDM model: 1991

Posted 06 May 2019 - 05:36 pm

I've just done a coolant flush and change so i'll have to wait until tomorrow to see if its done anything for it.

Yes the temp gauge does rise and in relation to the fan its wiring seems to be sealed to the back of it so not accessible to wire an external power source.

 

If you want to switch the fan, lift the tank and airbox to reveal the wiring, tank swivels up but support if more than half full.


Bigred mk1 R1 Calipers- Braided lines- Givi wing rack-Crash bungs- Hi vis bullets-PR2's- and a hoot to ride.

Quad 900 Silver Laser duo tech pipes-Scott oiler-Engine crash bars- Radiator mounted see me ring LED's-Datatool system 3 alarm -Centre stand- Extender fender-Renthal bars-Handle bar risers-Mirror extenders-BMW GS Handgaurds-Acumen uprated horn & Nautilus-Stainless steel Radiator guard-Givi wing rack-OEM screen-Yammy touring screen-MRA Vario-MRA Double bubble cut down for fast as fk riding-Tiger screen-Tank protector-Stomp grip panels-Optimate lead

 

1991 MK1 in need of some TLC watch this space  :) Sorted and on the Road Mick :P :P it's the bike that Jack built ;)


#6 Quadsey

Quadsey

    sticking around

  • Member
  • 22 posts
  • Location:Dublin
  • TDM model: 2006

Posted 06 May 2019 - 06:06 pm

 

If you want to switch the fan, lift the tank and airbox to reveal the wiring, tank swivels up but support if more than half full.

Good to know, thanks.


"Touch not, less ye be touched" -Brodie 1995


#7 TKH

TKH

    has been here 4ever

  • Member
  • PipPipPipPipPipPipPipPip
  • 1,868 posts
  • Location:Preston, NW England
  • TDM model: 2008

Posted 06 May 2019 - 06:31 pm

Make sure all the hoses are back in the right place. The small ones near the radiator cap sometimes get switched.

 

hoses

2008 black 900, Stebel 134db, Givi 42 ltr top box, Kapa rack, ciggy lighter, heated grips, BMW hand guards, tank bag, soft panniers, PR2s front and rear, K&N airfilter, airbox mod.,Bikevis lights, handlebar offset risers,

#8 Hombre

Hombre

    Carpe Addict

  • Supporting Member(thanks)
  • PipPipPip
  • 379 posts
  • Location:Mallorca
  • TDM model: 2004

Posted 06 May 2019 - 09:31 pm

Check the coolant isn't leaking past the seal on the water pump shaft. You need to know why the coolant is low.

BSA C15T, Ducati 200 Elite, Villiers Cub Trials Bitsa, Ariel Huntmaster, AJS 650 CSR, Sunbeam S7, Suzuki 650 Katana, Honda 400-4, Bultaco 350 Sherpa, Cotton Minarelli, Fantic 303, Yamaha SRX 400, Yamaha 550 Virago, Kawasaki ZZR 1100,  Fantic 305, Yamaha TDM 850 '91, Yamaha TDM 900 '04.


#9 wicklamulla

wicklamulla

    is it Jizzy Rascal time yet.....?

  • Supporting Member(thanks)
  • PipPipPipPipPipPipPipPip
  • 11,497 posts
  • Location:Parish of Cruwys (pronounced 'Cruise' just loike Tom) Morchard, Mid Devon.
  • TDM model: 1999

Posted 07 May 2019 - 01:28 am

 i tink the ECU can be programmed to switch the fan on at a lower temperature level.


spyball alarm/immob, bluespot brake calipers and Stainless hoses, Fournales air adjustable shock with Remote Resevoir, forks raised 10mm thru yokes, racetech linear fork springs in 15 wt oil, Kappa wingrack/luggage, heated grips, Kedo handguards, dual heat controller to power heated jacket liner and or pants!!, Stebel 136DB horn, K&N air filter, colour matched Baglux tank cover (magnetic tank bag modified to fit cover), osram +50% headloight bulbs, headlight protector,"NitramSpecial" parking loight, tail light indicators all running on LED's & incorporate "Lite Buddies", MK7 Scottoiler fitted, taller screen, 2-2 stainless steel CCC's, Devil stainless down pipes. MKI Renntec engine crash bars & sump guard.
engine changed july 2007 on a dyno run it made 79.1BHP / Torque 59.9Had a brief flirtation with a 1999 MKIIa but it blew an exaust valve on the M5 so was sold on to be repaired.

I loike tay and hang sangwiches !

www.kenhogantreeservices.co.uk

http://s33.photobuck...77/wickla/?sc=6



http://reg.imageshack.us/v_images.php

post-1-1150550733.gifpost-1-1150550726.gifpost-1-1150559830.gif


#10 Quadsey

Quadsey

    sticking around

  • Member
  • 22 posts
  • Location:Dublin
  • TDM model: 2006

Posted 07 May 2019 - 11:21 am

So i drove to work today (50km) and no issues, bike stayed as cool as usual and reservoir still has coolant in it. Can't say whether or not the fan kicked in. I might leave the bike running after my return journey tonight and see what happens.

 

In relation to some of the replies:

TKH, Pipes are as in your photo so don't think there's any issue there.

Hombre, I confident it's not an issue of leaking as I've never seen any stains or residue on the ground or bike.

Wicklamulla, Would getting the ECU altered be expensive?


"Touch not, less ye be touched" -Brodie 1995


#11 dablik

dablik

    Master Intermediate Fettlin' Award 2018

  • Supporting Member(thanks)
  • PipPipPipPipPipPipPipPip
  • 8,328 posts
  • Location:Bootleshire
  • TDM model: 1991

Posted 07 May 2019 - 04:23 pm

There's a topic on here where Fixitsan sent his ecu to Greece to be flashed, will depend on your model of ecu if i remember, try a search for info.


Bigred mk1 R1 Calipers- Braided lines- Givi wing rack-Crash bungs- Hi vis bullets-PR2's- and a hoot to ride.

Quad 900 Silver Laser duo tech pipes-Scott oiler-Engine crash bars- Radiator mounted see me ring LED's-Datatool system 3 alarm -Centre stand- Extender fender-Renthal bars-Handle bar risers-Mirror extenders-BMW GS Handgaurds-Acumen uprated horn & Nautilus-Stainless steel Radiator guard-Givi wing rack-OEM screen-Yammy touring screen-MRA Vario-MRA Double bubble cut down for fast as fk riding-Tiger screen-Tank protector-Stomp grip panels-Optimate lead

 

1991 MK1 in need of some TLC watch this space  :) Sorted and on the Road Mick :P :P it's the bike that Jack built ;)


#12 Karpo

Karpo

    sticking around

  • Member
  • 22 posts
  • Location:Switzerland
  • TDM model: 2010

Posted 07 May 2019 - 07:20 pm

There's a topic on here where Fixitsan sent his ecu to Greece to be flashed, will depend on your model of ecu if i remember, try a search for info.

 

Here ya go. 


2010 TDM900A


#13 Quadsey

Quadsey

    sticking around

  • Member
  • 22 posts
  • Location:Dublin
  • TDM model: 2006

Posted 08 May 2019 - 02:47 pm

Quick update: After driving home last night (50km) i left the bike idling, it heated up but never got to the red. So the coolant change has helped but i still didn't see the fan come on at any point.


"Touch not, less ye be touched" -Brodie 1995


#14 wicklamulla

wicklamulla

    is it Jizzy Rascal time yet.....?

  • Supporting Member(thanks)
  • PipPipPipPipPipPipPipPip
  • 11,497 posts
  • Location:Parish of Cruwys (pronounced 'Cruise' just loike Tom) Morchard, Mid Devon.
  • TDM model: 1999

Posted 09 May 2019 - 10:38 am

Quick update: After driving home last night (50km) i left the bike idling, it heated up but never got to the red. So the coolant change has helped but i still didn't see the fan come on at any point.

 

 

I keep reading this with regards to TDM 850's and 900's. have ya actually tested the fan by applying voltage to it?


spyball alarm/immob, bluespot brake calipers and Stainless hoses, Fournales air adjustable shock with Remote Resevoir, forks raised 10mm thru yokes, racetech linear fork springs in 15 wt oil, Kappa wingrack/luggage, heated grips, Kedo handguards, dual heat controller to power heated jacket liner and or pants!!, Stebel 136DB horn, K&N air filter, colour matched Baglux tank cover (magnetic tank bag modified to fit cover), osram +50% headloight bulbs, headlight protector,"NitramSpecial" parking loight, tail light indicators all running on LED's & incorporate "Lite Buddies", MK7 Scottoiler fitted, taller screen, 2-2 stainless steel CCC's, Devil stainless down pipes. MKI Renntec engine crash bars & sump guard.
engine changed july 2007 on a dyno run it made 79.1BHP / Torque 59.9Had a brief flirtation with a 1999 MKIIa but it blew an exaust valve on the M5 so was sold on to be repaired.

I loike tay and hang sangwiches !

www.kenhogantreeservices.co.uk

http://s33.photobuck...77/wickla/?sc=6



http://reg.imageshack.us/v_images.php

post-1-1150550733.gifpost-1-1150550726.gifpost-1-1150559830.gif


#15 chrisr

chrisr

    has been here 4ever

  • Supporting Member(thanks)
  • PipPipPipPipPipPipPipPip
  • 1,429 posts
  • Location:Surbiton, Surrey
  • TDM model: 2010

Posted 09 May 2019 - 10:57 am

You can also check the fan through the dash on diag mode, see JBX’s site for details
Black.Registered 2013.Scorpion Cans. Renthal 755s, Hyperpro front springs,15w fork oil,DL650 handguards,givi engine bars,led spotlights,gipro gear indicator,lengthened dogbones,LeeHenty CSM kit and stainless bits,Topsellerie seat,Nitron rear shock,MRA vario screen,grip puppies.PC III. K&N airfilter,Fenda extenda,

#16 Quadsey

Quadsey

    sticking around

  • Member
  • 22 posts
  • Location:Dublin
  • TDM model: 2006

Posted 09 May 2019 - 11:58 am

 

 

I keep reading this with regards to TDM 850's and 900's. have ya actually tested the fan by applying voltage to it?

No, as the wiring on the back of the fan is heat sealed and not accessible.


"Touch not, less ye be touched" -Brodie 1995


#17 PICARD

PICARD

    has been here 4ever

  • Supporting Member(thanks)
  • PipPipPipPipPipPipPipPip
  • 1,182 posts
  • Location:Wirral / wherever I lay my hat!
  • TDM model: 2004

Posted 09 May 2019 - 12:07 pm

See post #5 above.
Lock onto my co-ordinates and beam me up !!

04 900 - 92 mk 1 - r 1150 rs - Z550 A1 - 2x bonnies - plastic slug -XL185 - ...not in that order !! (and one or two i don't want / dare to own up to !!)

#18 wicklamulla

wicklamulla

    is it Jizzy Rascal time yet.....?

  • Supporting Member(thanks)
  • PipPipPipPipPipPipPipPip
  • 11,497 posts
  • Location:Parish of Cruwys (pronounced 'Cruise' just loike Tom) Morchard, Mid Devon.
  • TDM model: 1999

Posted 11 May 2019 - 09:39 am

You can also check the fan through the dash on diag mode, see JBX’s site for details

i had firgottan about that!  Thas a handy function.


Hey Guys, I'm still finding my way around my TDM 900 twin and today i decided to flush the cooling system because the bike is overheating in city driving conditions.

There are two main issues. 1. the fan doesn't seem to be coming on regardless of temp and 2. the coolant reservoir was empty.

 

So firstly after stripping the radiator off completely to access the fan, i found the fan is moving freely and has no signs of wear. It has been suggested to me to check "a switch" or "thermostat", i was unable to spot either. Does this sound like it could be the issue? Where are they located ( a photo pointing them out would be nice)

 

Secondly the coolant reservoir is completely empty, is this simply an issue of low coolant level or is there an issue with circulation?

 

Any help would be greatly appreciated, thanks.

here scaldy balls look at this link (i hope you can see it),  Look at code 51 which will test the fan fer ya.  https://www.tdm-yama...ex.php?page=MDG


spyball alarm/immob, bluespot brake calipers and Stainless hoses, Fournales air adjustable shock with Remote Resevoir, forks raised 10mm thru yokes, racetech linear fork springs in 15 wt oil, Kappa wingrack/luggage, heated grips, Kedo handguards, dual heat controller to power heated jacket liner and or pants!!, Stebel 136DB horn, K&N air filter, colour matched Baglux tank cover (magnetic tank bag modified to fit cover), osram +50% headloight bulbs, headlight protector,"NitramSpecial" parking loight, tail light indicators all running on LED's & incorporate "Lite Buddies", MK7 Scottoiler fitted, taller screen, 2-2 stainless steel CCC's, Devil stainless down pipes. MKI Renntec engine crash bars & sump guard.
engine changed july 2007 on a dyno run it made 79.1BHP / Torque 59.9Had a brief flirtation with a 1999 MKIIa but it blew an exaust valve on the M5 so was sold on to be repaired.

I loike tay and hang sangwiches !

www.kenhogantreeservices.co.uk

http://s33.photobuck...77/wickla/?sc=6



http://reg.imageshack.us/v_images.php

post-1-1150550733.gifpost-1-1150550726.gifpost-1-1150559830.gif



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users